Discussions

Ask a Question

How to add custom commands to wysihtml?

I'd like to add custom plugins to the richtext editor so that users can insert some custom liquid tags. In v2 with tinyMCE that was possible, but in V3 this looks different. Any idea?

Why are stylesheets and javascripts not minified on the engine?

From the v3.1 release notes I take it that the feature still exists, but only works under certain conditions: Wagon doesn't stop the whole site deployment if a JS/CSS can't be minified. What are those conditions/what can I do to make the minification work?

Pulling ContentAssets # Error description: undefined method `<' for nil:NilClass

Helle Support, every time we try to clone or backup our site from server to local we get "Pulling ContentAssets # Error description: undefined method `<' for nil:NilClass" and the pull is stopped. All pulling before are fine, "Pulling Site Pulling Pages Pulling ContentTypes Pulling ContentEntries Pulling Snippets Pulling ThemeAssets Pulling Translations" but the ContentAssets crash. What can we do to clean up the server so we get a working clone? Thanks

301 Redirect

We're running http://www.silvesco.com/ on the new Locomotive CMS. We've got some old .php pages showing up in Google search we'd like to do 301 redirects for. When we route /who-we-are.php to /about it doesn't work. When visiting /who-we/are.php we get a 403 error with "nginx" text. Any suggestions for how we might be able to get those redirects in place?

how to add anchor links in menu

My pages include multiple sections that i'd like to reference in the menu as sub-links (anchor links, with #) of the pages links. Example : I have a "Home" Page with 3 sections with ids "section-1", "section-2" and "section-3". In the menu I display the main "Home" link and when hovering this link i'd like to display 3 anchor links to go directly to the corresponding sections. Is it possible ? The "page" liquid drop doesn't seem to include the page content of sections, so I wonder how to achieve this. Thanks ! Grégoire

Filter Tag with with_scope doesne't work

Hi, i got a problem while trying to filter my blog entries through with_scope. In wagon my filter system it worked quiet well. But when i deploy it to my locomotive site it won't filter these entries anymore. Here is my Code: {% assign currenttag = params['tag'] %} {% with_scope tags: currenttag %} {% paginate contents.blog by 5 %} {% for post in paginate.collection %} <div class="blog-material"> <img class="blog-image" src="{{ post.image.url }}"> <div class="blog-body clearfix"> <h5><a href="{{ post._slug }}">{{ post.title }}</a></h5> <p>{{ post.text | truncatewords: 50 }}</p> <a href="{{ post._slug }}" class="button float-right">Weiterlesen</a> </div> </div> {% endfor %} <div class="row content-top-min content-bottom-min"> <div class="large-12 columns text-center"> {% if paginate.previous_page %} <a href="?tag={{currenttag}}&page={{paginate.previous_page}}" class="button arrow"> <i class="material-icons">arrow_back</i> </a> {% endif %} {% if paginate.next %} <a href="?tag={{currenttag}}&page={{ paginate.next_page }}" class="button arrow"> <i class="material-icons">arrow_forward</i> </a> {% endif %} </div> </div> {% endpaginate %} {% endwith_scope %}
ANSWERED

SSL Cert

We just launched a site using Locomotive Hosting, and we are receiving a ssl mismatch. The server is serving a ssl cert of "locomotive.works" which obviously is not our domain. I looked all over the documentation and found nothing on ssl certs, or anything in the back office where I could configure or upload a valid SSL cert. How do we get our cert onto the locomotive hosting server?
ANSWERED

how to set up custom domain for a website on a heroku-hosted locomotive

Hi, I just deployed my locomotive app successfully to heroku (using mongoDB Atlas instead of mLab since it's not available anymore). I was wondering how to set up a custom domain for a specific website and I found some answers [here](https://doc.locomotivecms.com/docs/domains), but unfortunatly it uses a IP redirection to work, and it seems to me that free heroku-hosted app have no static IP addresses. So the proposed solution does not seem to work in that case. Am I wrong ? If so, can you help me ? Thanks, Grégoire

Comment gérer les espaces insécables dans les paragraphes

J'aimerais arriver à gérer correctement les espaces insécables dans les paragraphes rédigés par les utilisateurs, notamment pour éviter les retours à la ligne avant une ponctuation. Une solution pour cela est d'utiliser &nbsp; , mais son utilisation dans l'éditeur rich text ne fonctionne pas et affiche littéralement "&nbsp;". Est-ce que vous voyez un moyen simple de gérer cela ? Via un script javascript ? Via un bouton dans l'éditeur rich text qui permettrait d'insérer un espace insécable ? Merci d'avance, Grégoire